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Chapter 1 
Introduction 

FormCliQ™/Invoices 2010 Edition is a Windows® application that lets you scan invoices 
you receive, capture data from them, quickly enter the data in these documents and create 
data files ready to be transferred into your accounting package. FormCliQ also archives 
images of these documents, and allows you to search them and find one or more documents 
of interest from within FormCliQ, or anywhere on your desktop quickly and easily. 

When entering data, FormCliQ replaces the manual data keying process you would normally 
follow. This reduces the chances of data entry errors. It also saves time.  

�  FormCliQ/Invoices reads forms with printed data only. Forms with handwritten data can 
be scanned, but their handwritten fields should be typed manually.  

�  FormCliQ/Invoices creates data files that contain the recognized and typed data. If you 
wish to transfer this data to your accounting system, you need to prepare additional utility 
for such task.  

FormCliQ employs advanced optical character recognition (OCR) and other unique and 
patented technologies to recognize each individual invoice and to scan and locate important 
information, such as the Due Date, Terms, Amount, Quantity, etc.  

FormCliQ provides integrated editing capabilities that allow you to fix scanning errors.  

FormCliQ has three main windows that you use to scan documents, process and verify them, 
and search through all of your scanned invoices.  

Overview of FormCliQ/Invoices 

 Using FormCliQ/Invoices 

You may apply FormCliQ/Invoices for either one of these purposes, or both: 

Capture data from invoices and transfer it to your accounting package. This replaces the 
process of manually keying data and saves you time, and assures you of more accurate data 
because of high OCR accuracy and the validations FormCliQ performs. 

Every document you process in FormCliQ is automatically indexed based on its content and 
its image is stored in an archive. You can search and retrieve documents easily and quickly 
from anywhere on your desktop. 
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 Scanning Invoices from a Vendor 

FormCliQ/Invoices let you use any TWAIN compliant scanner to scan invoices.  

Entering the first invoice from a vendor is different from entering the rest of the vendor’s 
invoices because you use the first invoice to configure FormCliQ to recognize that invoice 
type. 

After the first time setting up FormCliQ to locate the data fields in an invoice, you can just 
scan and process subsequent invoices. FormCliQ will recognize the invoice layout and 
extract all of the required invoicing data.  

 Entering Data with OCR-on-CliQ 

FormCliQ tries to locate the necessary data fields and extract them from any new invoice. If 
FormCliQ doesn't find the data, then the typist needs to fill the data manually. This is 
normally done with just one mouse click! The typist clicks on the image where the data is 
located, FormCliQ finds this data near the mouse click and extract it as if it was typed, and 
furthermore, the next time this invoice type appears in the system – FormCliQ will 
remember the location of the old field and extract it automatically from the new invoice. All 
this is done in the background with just one mouse click! 

 Archiving, Accessing, and Retrieving Documents 

Invoices you process using FormCliQ are automatically indexed, and archived in FormCliQ. 
At any later time, you may access these documents, by clicking on a string of characters 
which is your invoice number. You may do so regardless of the application you are working 
in, from anywhere on your desktop. 

 Integrating FormCliQ into an Accounting System 

FormCliQ performs the kernel work of invoice processing: automatic recognition and data 
entry from scanned documents. To integrate FormCliQ into a larger accounting or ERP 
system like QuickBooks, SAP and others – it is needed to create several text files (like the 
list of accounts) and also it is needed to read the result FormCliQ files, in XML or CSV 
format, and pass their content into your accounting system. 

Details about this can be found in the chapter Integrating FormCliQ into an Accounting 
System. 
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Chapter 2 
FormCliQ Installation 

 

What You’ll Need to Install FormCliQ 

To install and use FormCliQ, you will need a desktop scanner (TWAIN compliant) with or 
without document feeder. This is optional, because you may scan with another software and 
import the image files manually. However, using FormCliQ scanning produces very high 
quality image files with FormCliQ's internal proprietary algorithms, and other scanner 
software might produce images with lower quality. 

Detailed System Requirements 

 Supported operating systems 

FormCliQ is supported under the following operating systems: 

Windows 2000 (SP3 or later) 
Windows XP (SP2 or later) 
Windows Server 2003 / 2008 
Windows Vista 

 Scanner 

FormCliQ image capture operates in one of two modes: 

Direct scan mode (scan from FormCliQ): Any TWAIN compatible scanner 
Indirect scan mode (open files): scanner is not required 

�  For all but the lowest of page volumes, it is recommended to apply a scanner with 
Automatic Document Feeder (ADF). 

 Image File Format 

FormCliQ supports the following image file formats: 

TIFF uncompressed 
TIFF compressed in CCITT Group 3 and 4 
JPEG 
BMP 



 

FormCliQ User Guide; Doc. Rev. 2010.04.26, Page 8 

 Minimum Computer Configuration 

FormCliQ runs best on the following minimum hardware configuration: 

Pentium 4 1Ghz or higher 
512 Mb Random Access Memory (RAM) 
150 Mb hard drive free space (depending on size of archive) 

�  Internet connection is required for product activation only (see below). 

Installing FormCliQ 

To install FormCliQ, launch the installation file you downloaded from our site and saved to 
your hard drive or from the FormCliQ installation CD if you received one.  
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Accept the FormCliQ on-line End User License Agreement (EULA): 
 

  

FormCliQ Invoices 2010 supports invoices from Australia, Canada, Germany, Spain, United 
Kingdom, and United States. You may decide to install only support of invoices from your 
country, or for all of countries. If you plan on using FormCliQ for one country only, select 
Custom: 
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If you selected the Custom path, when prompted with the list of available options, click on 
the desired countries and select “Entire feature will be installed on your local hard drive.” 
For countries that need not be supported, select "Entire feature will be unavailable". 
 

 

Click Next. You will get the screen below: 

 

Click Install. The installation is now completed. 
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Running FormCliQ for the First Time 

There are a few selections you will be asked to make when you run FormCliQ for the first 
time. They will be valid for subsequent logins, and you only need to modify them later on 
for specific reasons. 

First, it prompts you to set a working directory for data and other functions:  
 

 
 
Accept the default choice, unless you have a reason to change it. In case that you want that 
FormCliQ will work in a network, meaning that you will be able to view the files than other 
station scanned, then you need to define a directory that is shared by several stations. 

 FormCliQ Companies 

The FormCliQ operating environment is determined by the company you select and log into. 
Before you may select of a company, you must create at least one. 

From the Login window: 

  
 
Click on the Login button and you will need to select a Company Class. 

 FormCliQ/Invoices Company Class Screens 

FormCliQ/Invoices user needs to select one the company classes available. 
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As you create the company you’ll need, you have to provide the company name. It is 
possible to install several companies in the same FormCliQ installation. 

 

�  While you may need, or wish, to create several companies to perform your work in 
FormCliQ, in the vast majority of cases they should all be of the same class. Archived 
documents can only accessed when the user is logged under the same company. 

Next, you will set the password for the company you created: 

 

Your Archive company setup is complete, and you are ready to use FormCliQ. 
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Click OK, and proceed to create the company password: 

 

Your company setup is complete, and you are ready to use FormCliQ. 

The next chapter describes how to use FormCliQ. 

 

Activating FormCliQ 

FormCliQ is only available via a digital download from one of several websites. It is 
provided on a free, no obligation, evaluation basis, or under a purchase. When you purchase 
FormCliQ, we send you a registration serial number that is unique to you, and activation 
instructions. 
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Chapter 3 
FormCliQ Commands and Operating 
Modes 

 

Menu Commands 

The same menus and menu commands are available in all three of the FormCliQ windows. 
Each of the menus is described below.  

 File 

 Select company 

Use the File > Select Company command to choose the specific company to apply next time 
you use FormCliQ. The Manage Companies dialogue box lets you create and manage the 
multiple companies you may have as you use FormCliQ: 

 

As you change the company selection, you will need to log into the company you selected 
using the previously defined password. 
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 Exit 

Use the File > Exit command to close FormCliQ and exit.  

 Edit 

The Edit menu items may be grayed on occasions. When the Edit menu is active (in the 
Process/Jobs mode) you may use its commands to perform certain operations while you 
process documents.  

 Cut, Copy, Paste 

You may use these commands to manage page images in jobs you process. 

 Insert Row, Delete Row 

When processing tables in documents such as invoices, you can insert or delete line items as 
needed. 

 Remove Document 

Delete documents you do not need from the archive using this command. 

These operations are described in the applicable sections of this User Guide. 

 View 

Use the View commands to display pages in a job, or highlight data fields as you process 
them. You may also advance forward or backward through the pages in a job while in Process 
or Jobs mode.  

 Tools 

 Scanner 

Use the Select Scanner command to set the scanner of your choice. 

Depending on the nature of the documents you wish to scan, you will need to adjust the 
Scanner Options for the type of documents you scan (Simplex or Duplex), or for best results. 

At the start, we recommend that you accept the default selections until you become familiar 
with their effect on the scanner. Selections you make are set until you change them. 

 Backup 

You may use the Tools > Backup command to create a copy of the FormCliQ databases of 
images and data: 



 

FormCliQ User Guide; Doc. Rev. 2010.04.26, Page 16 

 

You define the backup location using Tools > Options > Backup (see below). Press Start, and 
Exit when the backup operation is complete. 

 Restore 

Use this command to restore your data from a previous backup: 

 

 Change Login Password 

If you must modify your login information, select Change Login Password, and enter the new 
information you wish FormCliQ to preserve: 
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This change applies to the present company only. 

 Options 

The Tools > Options dialogue box contains four different tabs: 

Preferences 
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Auto Rotate – clicking this will make FormCliQ try to find the correct rotation of the page. If 
the page is landscape or upside down – FormCliQ will rotate it automatically. This step is 
important but it slows down a bit the capture process. Uncheck this only if you are absolutely 
sure that the images are vever rotated, or if you are going to rotate each image manually. 

Show All Buttons – this will show additional buttons in Capture screen. All these buttons are 
accessible from the menu. 

Show Thumbs in Search Screen – this will show thumbnails in the search result screen, 
however, if there are many search results, this might slow down the search screen display. 

Export image as – select one of the possible image file formats: TIF, PDF or Searchable PDF. 
Using searchable PDF will let you find text with Acrobat "Find Command". However, this 
format requires full page OCR and it will make page processing slower. 

Database definition – select the database you want to use for storing the data for future 
searches. CharacTell supports Microsoft Access format as well as other databases. However, 
if you decide to use other databases, it is your responsibility to make sure that the connection 
works and the connection string is properly defined. Failure to do so will result with data that 
will not be exported. If you select other format rather than Microsoft Access, you will need to 
consult your system administrator or local reseller in case of support problems. 

Backup 

In this tab you need to define the directory in which backups will be stored. 

 

Fields 

This tab allows you to set the exact document types you will be able to use, and hide or allow 
some or all of the data fields. 
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The available list of fields seen in the right pane is dependant on the document type you click 
on in the left lane. 

 Help 

 Content 

FormCliQ contains detailed, context sensitive on-line help. You can reach it from 
Help/Content, or by pressing the F1 function key. 

 User Guide 

A complete User Guide (this document) and is included. 

 Tutorials 

This command takes you to the FormCliQ website (www.formcliq.com) where you can view 
several animated tutorials that illustrate various key FormCliQ processes and uses. We 
strongly recommend that you take the time to view them as early as possible after you install 
FormCliQ. 
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 Problem Report 

In case you encounter a problem while using FormCliQ, the Help/Problem Report menu item 
makes it easier to report the problem to us. 

 

Mark the items that apply and, when possible, check the box to also include the image you 
were working on when the problem occurs. Your report will be sent to special e-mail address 
where our technicians and engineers will examine it without delay. 

 Activate 

The Activate menu item is used to activate your installation or upgrade. You will receive 
instructions regarding this procedure in email. 
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Capture Window 

The FormCliQ Capture window, shown below, is the first screen that appears when your start 
FormCliQ. You use the Capture window to scan documents into the system.  

  
Document Types 

The Document Type list-box lets you specify the type of documents you are going to scan and 
process. This choice determines how the scanned page(s) will be processed by FormCliQ.  

�  Sometimes, like in some versions of FormCliQ/Invoices, there is only one available 
document type. In this case the document type combo-box will not be displayed. 

  

 Capture Commands 

The FormCliQ Capture window commands are described below.  

 Select Scanner  

Click the Select Scanner button to select the system scanner you want to use for scanning 
documents into FormCliQ. 
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You only need to select the scanner once. You may modify that selection at a later time, if 
needed. 

�  Twain (LeadTools) and Twain (DynamSoft) are software components that work properly 
with scanners that work with full Twain compatible drivers. However, some scanner drivers 
are not fully Twain compatible. There are such scanners that work best with LeadTools and 
not DynamSoft or vice versa. If you have problems to operate your scanner, try to use the 
other scanner family. 

After you select the scanner family, you will be prompted to select the scanner. This is 
important when you have several scanners tat are connected to your computer: 

 

 

 Scanner Options  

Click the Scanner Options button to configure the options for the currently selected scanner. 
The options may vary depending on the scanner. Common options are described below. 

 

Duplex – use that to scan both side of every page. This will work only for scanners that 
support Duplex. 
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Stop on Empty Page – the ADF scanning will stop when an empty page is encountered. 

Show Twain GUI – show the Graphical User Interface that comes with the scanner driver. 
Select this only if you want to use specific scanning parameter that is not supported in the 
regular Twain software, or when the scanner is not fully Twain compatible and you cannot 
scan without the scanner GUI. 

Brightness – a number in the range 0-100. Higher brightness number produces brighter 
image. 

Contrast – a number in the range 0-100. Higher contrast number produces sharper image. 

Adaptive – this option is useful for low/medium quality paper. This instructs the scanner to 
scan in gray level and use internal FormCliQ algorithm to produce better binary image. The 
result is better quality images and sometimes slower scanning. 

ADF – use the ADF (Automatic Document Feeder) and not flatbed. This parameter is 
important for scanners that have both flatbed and ADF. 

Flatbed – use the flatbed and not ADF. This parameter is important for scanners that have 
both flatbed and ADF. 

Flatbed Splits – use the flatbed to produce several documents at once. This is useful for small 
documents like Receipts. You may put several receipts on the flatbed, making sure that they 
don't touch each other, and FormCliQ will produce several documents in each scan. 

Split Height – a parameter to the Split algorithm. "Automatic" means that the split is done 
automatically and FormCliQ uses the black background of the scanner cover. 

  

 Scan  

Click the Scan button when you are ready to scan a document or a batch of documents in your 
ADF.  

 Open File  

Click Open File to open an image of a previously scanned and saved image.  

 Delete Page  

Use the Delete Page command to delete the currently viewed page.  
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 Delete All Pages  

Click Delete All Pages to delete all scanned pages the currently viewed document.  

 Process  

Click the Process button to begin processing the document.  

 Add to Queue  

Click the Add to Queue button to send the scanned document to the FormCliQ Queue. From 
the FormCliQ Jobs window you can process the document. The Jobs window lets you scan a 
number of documents at once, queue them and then process them all later, at a convenient 
time. This splits the work into two tasks: scanning and queuing the documents and processing 
them.  

 Thumbnail View of Current Page  

A thumbnail image of the current page appears in the left pane of the Capture window.  

 

Jobs Window 

In the Jobs window you are able to view pages you scanned but did not process yet, or 
documents that you have added from the Capture window to the processing queue.  
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The top part of the window lists each scanned document in a row.  

Click on a row in the top half to view the image in the bottom part of the window. 

Click on the dividing line to toggle the page view from a half window to a full window view.  

Click on the dividing line again to restore a split window view of queued documents and 
pages.  

When you process a batch of documents, the title Jobs changes to Process, and another group 
of relevant action buttons and data appears in the left pane: 
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 Jobs Window Commands 

 Process  

Select a document in the Jobs window then click the Process button to process the data.  

 View  

Select a scanned document from the queue and then click the View button to see the image of 
the selected document.  

 Delete  

Click the Delete button to delete the currently selected document from the queue.  

 

 Thumbnail View of Current Page  

A thumbnail image of the currently selected document is shown in the left pane of the Jobs 
window.  
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 Page Selector  

The Page Selector at the bottom of the left pane lets you select specific pages to view from 
documents that are multiple pages. The Page Indicator shows the current page being viewed 
and the total number of pages in the document.  

 Process Window Commands 

The Process window, shown below, appears when you click Save and Close in the Select 
Vendor dialog box.  

Use the Process window to locate the document data fields in the scanned image. FormCliQ 
automatically fills in the Vendor field and puts the prompt in the Invoice Number field to 
begin.  

To process the data fields, use the cross-hair cursor to draw a box around the location of each 
data field in the scanned document image. FormCliQ automatically tabs to the next required 
field after scanning and entering the information you select in the current data field. Continue 
this process until all data fields have been located, scanned and entered, then click Send at the 
lower left of the Process window.  
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 Stop  

Click Stop to cancel the processing.  

 Skip Page  

Click Skip Page to skip to the next page of a multi-page document.  

 Fields  

For each field the content of the field is displayed and you may type and change the content of 
this field in this box. 

To enter or change the value of a field, you may type it, or click on the image that contains the 
data item you wish to type. It is recommended to click since by clicking you do not need to 
type the data, and furthermore, FormCliQ will remember the location of the click and will try 
to recognize the data element even without clicking next time! 

 

Search Window 

The FormCliQ Search window, shown below, lets you view and search for documents that 
you have previously scanned.  
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 Search Options 

FormCliQ provides Search options in the left pane of the 
window, as shown in this figure.  

FormCliQ enables you to search in a number of ways 
depending on the document type involved.  

Under any search mechanism, select any of the document 
information that you have to search through the database of 
scanned documents to locate a document.  

 

 

 Searching for a Document in FormCliQ 

To search through your scanned documents for a specific one, you can use as little or as much 
information that you have about that document.  

Select the FormCliQ Search window.  

Enter the Search criteria in the fields in the left pane of the Search window. You can select 
any one or any combination of search criteria.  
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Click the box to the left of the field to select that search option. 

Enter the information to search for in the field. If you are searching by Vendor, you can select 
a vendor from the drop-down list.  

Click the Search button - .  

 Searching for a Document outside FormCliQ 

You may search for every document you processed with FormCliQ from any other application 
or screen on your computer using FormCliQ’s Search-On-Click™ feature. 

While in another screen or application, apply the Search-On-Click keys-mouse combination 
you set in the Options dialogue box. FormCliQ will take you to the Search window, and will 
display the document(s) that contain this index. 

Example: Let’s say that a customer send you an email asking for a copy of a certain invoice. 
While in your email program, click-mouse on the invoice number, and here it is! 

Click CTL-ALT + Left mouse on “S06258” in the email message,  

 

and FormCliQ displays: 



 

FormCliQ/Invoices User Guide; Doc. Rev. 2010.01.10, Page 31 

 

the invoice containing this number!!! Now you may use the mail/save/print buttons to transfer 
this invoice to the requester. 

 

 



 

FormCliQ User Guide; Doc. Rev. 2010.04.26, Page 32 

Chapter 4 
FormCliQ/Invoices Advanced Topics 

 

Using Accounts / General Ledger Codes 

Accounts (sometimes called General Ledger Codes or GL Codes) are mandatory in every 
accounting system. Accounts are not included in the invoice, but they must be added to every 
invoice or every item line in order that the data will be transferred to the accounting system 
properly. 

To use Accounts inside FormCliQ/Invoices requires several steps. 

 Creating Accounts Lookup Table 

Accounts (GL Codes) must correspond to existing accounts in your target system. Accounts 
may be different for different companies. Therefore, you should create a lookup table for each 
company. The lookup table is just a text file with the name Accounts.dct, and it should be 
located in FormCliQData\CompanyName\Dicts directory. 

This is a typical content of Accounts.dct file: 

Accounts.dct 

Automobile 
Bank service 
Communication 
Equipment rental 
Insurance 
Licenses and permits 
Miscellaneous 
Professional fees 
Rent 
Repairs 
Travel 

 Activating Account Fields 

Now you need to activate the Account fields. Open Tools/Options/Fields from the main menu 
and activate one of Invoice Account / Item Account / Invoice GL Code / Item GL Code: 
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 Filling Account Fields 

When you will process a new invoice, this field will be displayed and show you the list of 
available accounts: 
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Row Balance 

FormCliQ performs data test to make sure that there is no typing errors. For each row in the 
invoice items table FormCliQ validates that price*qty=item amount (or more complicated 
formula if item discount is active). If there is a typing error, a message is displayed at the 
bottom bar: 

 

 

Defining a Document with Several Pages 

Invoices that contain many items may have several pages. In such invoices the amount 
appears on the last page. If you try to leave the invoice amount empty, FormCliQ does not 
allow it, and displays a message , 
recommending that you will define the next page as a continuation of the current page. 

To do this, press F5 and you will have the screen below: 



 

FormCliQ/Invoices User Guide; Doc. Rev. 2010.01.10, Page 35 

 

Now you can compare the two pages (current and next) and decide whether the next page 
continues the current. If it does (e.g.: they have the same Invoice Number) then click on Yes. 
Then click Enter and jump to the next page of this invoice. 

Invoice Balance Tool 

When typist tried to proceed to the next invoice after filling the Invoice Total, FormCliQ tests 
that the total is equal to the sum of all items (sometimes using more complicated formula, if 
fields like GST or Discount are activated). If the total amount is not equal to the calculation, 
i.e the entire page is not in balance, FormCliQ displays the error message: 

.  
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You should click F6 and the Documents Balance Correction Tools box appears: 

 
 

It shows you the resulting amount in each line in editable boxes to the right of each line, as 
well as the total (not seen in this example because it is located at the next page). You also see 
the totals for the invoice: the amount that was read from the page, the amount that was 
calculated as the sum of all the lines in it, and the difference between them.  
 
Use this information to identify the source of the page inconsistency. The most common 
possibilities are: 
 
1) The total amount of the page was read incorrectly. 
 
2) A line (or more) of the table was (were) not identified as a line and is (are) missing. 
 
3) There is an additional cost (like Freight or Discount) that should be added to the 
calculation. In such case you can add a new item line with this cost. 
 
To correct an incorrectly read total amount, just type the correct number in the edit box next 
to the Total field. You may have to scroll down to see it. Use the delete or add lines tools in 
the bar below the image to correct errors that are related to duplicated or missing lines by 
adding or deleting them, as needed. 
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Skipping Invoice Items Using FormCliQ 

FormCliQ allows you to skip processing the items in the bill table individually, and instead 
assign the entire bill to one expense or item.  

 

 

Check or uncheck the Skip Table box above the table to activate or skip table processing:  

 

If you skip the table processing, you do not need to fill the table data. 
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Chapter 5 
Integrating FormCliQ into an Accounting 
System 

 

Audience 

This section is provided for System Administrators or Software developers who wish to 
integrate FormCliQ/Invoices into their ERP or Accounting system. 

Integration Topics 

Integrating FormCliQ requires the following tasks: 

�  Create Accounts (GL Codes) lookup table 

�  Create Vendors lookup table (optional) 

�  Create Vendor Terms lookup table (optional) 

�  Import typed invoices into your accounting system 

 Create Accounts (GL Codes) lookup table 

This step was described in details in the section Using Accounts / General Ledger Codes. 
Basically, it requires that you would create a file Accounts.dct with each expense account in 
a separate line, and put this file in the directory FormCliQData\Your Company\Dicts. 

 Create Vendors lookup table 

This step is optional. Typist may type any vendor name even if it is new. However, if you 
create a lookup table file before using FormCliQ, then the list of vendors will be provided and 
it will be easier to pick the correct vendor name in case the vendor is not new. 

This requires that you would create a file Vendors.dct with each Vendor in a separate line, 
and put this file in the directory FormCliQData\Your Company\Dicts. 
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 Create Vendor Terms lookup table 

This step is mandatory only if you activate the Vendor Terms field. Vendor Term (e.g.: Net 
30) should be also extracted from your accounting system and created in the file Terms.dct 
with each Vendor Term in a separate line, and put this file in the directory 
FormCliQData\Your Company\Dicts. 

 Import typed invoices into your accounting system 

FormCliQ export the typed data into XML and CSV files, and the images are stored in TIF or 
PDF files. These files are located in FormCliQData\Your Company\DataExp and 
FormCliQData\Your Company\ImageExp. 

 


